Problem mit Y und Z im Itemnamen beim staticen

Antworten
Nachricht
Autor
Sirius
Administrator
Beiträge: 713
Registriert: 07 Feb 2004 17:17
Kontaktdaten:

Problem mit Y und Z im Itemnamen beim staticen

#1 Beitrag von Sirius » 01 Nov 2010 22:34

Wir haben gerade reproduzierbar festgestellt, dass der Mulpatcher wohl Probleme hat wenn man im Worldeditor eine WSC läd die Items enthält deren Namen ein Y oder Z vor einem Leerzeichen enthalten. Also z.B. lilly pad. Er stürzt dann immer ab mit der Meldung, dass er einen Integer erwartet. Ändert man in der WSC alle lilly in lilli funktioniert es problemlos.

Kennt von euch jemand das Problem? Oder weiss vielleicht sogar jemand wie man das beheben kann ohne die WSC verändern zu müssen?
-
--> No Signature <--
---

Incanus
Junior Mitglied
Beiträge: 61
Registriert: 04 Feb 2004 16:29
Kontaktdaten:

#2 Beitrag von Incanus » 07 Nov 2010 18:55

Wie man das ganze mit dem Mulpatcher beheben kann, weiß ich nicht.
Aber ich könnte dir einen erweiterten CentrEd Client (oder den Source, falls du selber kompilieren willst) zukommen lassen, mit dem sich WSCs direkt auf den CentrEd Server importieren lassen.

Sirius
Administrator
Beiträge: 713
Registriert: 07 Feb 2004 17:17
Kontaktdaten:

#3 Beitrag von Sirius » 07 Nov 2010 23:08

Oh cool, das ist ja Klasse! Darauf hab ich schon die ganze Zeit gewartet. Immer gern =) Selber kompilieren lieber nicht, das wird bei mir sicher schief gehn *gg* Wuerds zur Not aber auch mal probiern.
-
--> No Signature <--
---

Incanus
Junior Mitglied
Beiträge: 61
Registriert: 04 Feb 2004 16:29
Kontaktdaten:

#4 Beitrag von Incanus » 08 Nov 2010 01:42

http://download.skariatain.net/CentrED_wsc_import.rar

Basiert leider noch auf der Client Version 4.1, da ich noch keinen Zeit den Code auf den neuen Client zu portieren. Musst dir also eventuell die 4.1.er parallel zur aktuellen installieren und dann die centred.exe ersetzen.

Sirius
Administrator
Beiträge: 713
Registriert: 07 Feb 2004 17:17
Kontaktdaten:

#5 Beitrag von Sirius » 08 Nov 2010 10:18

4.1 ist perfekt :) Arbeite derzeit sowieso noch unter Win2k, da ist der 4.1er der letzte der läuft.
Danke für den Link! Werd ihn die Tage gleich mal ausprobiern.
-
--> No Signature <--
---

Antworten